Changes between Version 2 and Version 3 of YumPackageUpdates

Show
Ignore:
Author:
james (IP: 65.172.155.230)
Timestamp:
02/09/09 21:09:52 (9 years ago)
Comment:

--

Legend:

Unmodified
Added
Removed
Modified
  • YumPackageUpdates

    v2 v3  
    2525 
    2626  # pkgB-2.3.4-5 
     27  Conflicts: pkgA <= 1.2.3-4 
     28 
     29...to stop that. For compatibility you may also want to do: 
     30 
     31  # pkgB-2.3.4-5 
    2732  Provides: pkgA 
    2833 
    29 ...for compatibility with packages which "Requires: pkgA" 
     34...as now packages which "Requires: pkgA" will continue to work.  
    3035 
    3136== Package split == 
    6166Now pkgA will be updated and automatically remove the old pkgA-foo-1.2.3-4. 
    6267 
     68== Package update, requires newer interface == 
     69 
     70A package depends on something else, and older versions will fail. 
     71 
     72 * pkgA-1.2.3-4 is installed 
     73 * pkgB-3.4.5-6 is available 
     74 * pkgA-2.3.4-5 is available 
     75 * pkgB-4.5.6-7 is available 
     76 
     77The obvious solution here is: 
     78 
     79  # pkgA-2.3.4-5 
     80  Requires: pkgB >= 3.4.5-6 
     81 
     82...which will bring the new version of pkgB along if pkgA is updated. 
     83 
     84== Package update, fails with older interface == 
     85 
     86A package _doesn't_ depend on something else, but older versions will fail. 
     87 
     88 * pkgA-1.2.3-4 is installed 
     89 * pkgB-3.4.5-6 is available 
     90 * pkgA-2.3.4-5 is available 
     91 * pkgB-4.5.6-7 is available 
     92 
     93The obvious solution here is is to do the require, but in fact you want to do: 
     94 
     95  # pkgA-2.3.4-5 
     96  Conflict: pkgB < 3.4.5-6 
     97 
     98...this will update pkgB, if it's already installed, but do nothing otherwise. Also note that Conflicts are on package names only, if pkgB is renamed to pkgZ at version 3.4.5-6 (and provides pkgB of the same version) then the conflict do nothing.