Changes between Version 5 and Version 6 of whatsnew/3.2.28

Show
Ignore:
Author:
james (IP: 65.172.155.230)
Timestamp:
05/03/10 16:34:59 (8 years ago)
Comment:

--

Legend:

Unmodified
Added
Removed
Modified
  • whatsnew/3.2.28

    v5 v6  
    1010== User Interface changes == 
    1111 
     12 * Can pass multiple arguments to "yum check". 
     13 * Ignore "yum check" problems with packages being removed. 
     14 * Add total remove size, when just doing removes. 
     15 * Move protect-packages plugin into core, defaults to: "yum, glob:/etc/yum/protected.d" 
     16 * Add glob: syntax to all options which are lists. 
    1217 * Add '''simple''' unfilled requirements test, when we compare providers. 
    1318 * Add deselections to install, update, downgrade, remove (Eg. install @blah -foo).  
    2833== Significant bugfixes == 
    2934 
     35 * Setup the permissions on the yum.log file. 
     36 * Fixes for double prepending installroot (preupgrade/etc.). 
     37 * Catch the new 4.8.0 can't open rpmdb error. 
    3038 * Depsolving problems where obsoleting packages don't provide the thing we required from their obsoletee. 
    3139 * Workaround MD reget problems. 
    4351== API changes == 
    4452 
     53 * Catch the new 4.8.0 can't open rpmdb error. 
     54 * Remove all internal uses of has_key, for py3k compat. 
    4555 * Add tsInfo.deselect() for anaconda/kickstart. 
    4656 * Add pkg.obsoletedBy(). 
    5363 
    5464{{{ 
    55 3.2.28 -  74 commits: Tue Apr 20 18:10:22 2010 -0400 
     653.2.28 -  99 commits: Fri Apr 30 18:17:33 2010 +0200 
    5666 
    5767?? files changed,   ?,??? insertions(+),   ?,??? deletions(-)